Designing for the laser cutter

From MakeICT
Jump to: navigation, search

Resources

The LightBurn software is great for interfacing to the laser cutter and has basic drawing tools, but you are generally better of doing your designs in dedicated design software. Here are some options:

Rasters

LightBurn can be used to etch raster images (jpg, png, bmp, etc) with some caveats:

  • Lightburn will accept a full-color image, but will process it as gray scale. Remember there are not colors in laser cutting, the laser only cuts in one color (burnt).
  • Lightburn can scale the power of the laser according to the brightness or darkness of each pixel. As it scans your raster, it will attempt to modulate the power. There is some reaction time involved so the slower your scan, the better resolution you'll have across power levels.
  • Dithering an image can yield good results
    • Scale up your image
      • In GIMP, select Image > Scale...
      • I'd recommend 300dpi. You'll need to know your desired physical size and do the math to figure out how many pixels that is
    • And convert your image to a black-and-white dither
      • In GIMP, select Image > Mode > Indexed...
      • Select "Use black and white (1-bit) palette"
      • Set "Color dithering" to your desired effect (probably something besides "None").
    • You may find better control if you convert to grayscale first, tweak brightness/contrast/levels, and then dither.

Dither examples

Size No dither Floyd-Steinberg (normal) Floyd-Steinberg (Reduced) Positioned Original
Regular Founders-no-dither.png Founders-floyd-steinberg-normal.png Founders-floyd-steinberg-reduced.png Founders-positioned.png Founders-original.png
2x scaled Founders-scaled-no-dither.png Founders-scaled-floyd-steinberg-normal.png Founders-scaled-floyd-steinberg-reduced.png Founders-scaled-positioned.png

Vectors

Recommended Inkscape Settings

  • Change the bounding box option from "Visual" to "Geometric". This will exclude the stroke width in the calculation of shape dimensions (which are also ignored in DXF, LaserCut, etc). To do this,
    • Edit > Preferences
    • Select "Geometric Bounding Box"
  • Set the document page size to the size of your media. This makes it easier to visualize your design (File > Document Properties)
  • It's also recommended that mm is used as the default unit

Tracing

Inkscape has some pretty sophisticated vectorization algorithms built-in. This means that you can feed it a raster-type image, and it can generate a vector trace from it. This can be used to generate cut paths from a raster image - if you brought the image directly into LaserCut instead, it would only allow you to engrave it.

It can also be useful for including an image with vector designs in a single file.

Original Traced
Bat-and-rob-original.png Bat-and-rob-traced.png
  • For line work (black-and-whites, line-drawings, cut-outs, silhouettes, etc), you'll probably want to use "Brightness Cutoff"
  • To preserve/separate colors, select "Colors" under "Multiple Scans"
    • Be sure to uncheck "Stack scans", or your shapes will overlap (and be lasered multiple times!)

DXF export from Inkscape

Inkscape can generate DXF files, which can be imported into LaserCut.

  • Always save your file as .SVG - this is the native file format for Inkscape and preserves data. Use the "Save a copy" feature to export alternative file types.
  • Text and some other shapes must be converted to paths before they will appear in the DXF.
    • To make sure everything is a path before you export:
      • Edit > Select all in all layers
      • Path > Object to path
    • You will lose the ability to modify some properties of some objects, like changing a text's font or a rectangle's rounded corners
    • Images cannot be converted to paths in this manner. To do so, see the "Tracing" section
  • To export the DXF,
    • Select File > Save a copy...
    • Set the file type to "Desktop Cutting Plotter (AutoCAD DXF R14) (*.dxf)"
    • Uncheck ROBO-Master and LWPOLYLINE
    • Set the Base unit to 'mm'
    • Layer export works as expected

DXF import to LaserCut

  • Make sure that Inkscape has finished saving the DXF before you attempt to import it. The status bar will give an indication when it is complete
  • Occasionally, LaserCut will fail to import a DXF properly. If this happens, close the application and try again. Sometimes, you may need to try more than twice. Weird, I know.
  • Make sure your drawing is positioned on the virtual bed in the workspace. It's actual position doesn't matter if you're in immediate mode (default), but the software does weird things if you're off the virtual table. The easiest way to do this is to select everything, and then Center to Table
  • Paths will come in as segments. If you plan to do any engraving you must unite lines, but it's a good idea to do no matter what (Tools menu).

Useful extensions

  • Render > Hershey Text for simple vector fonts (these laser much faster than filled our outlined fonts)
  • Render > Gear... for generating paths in the shape of gears. Remember that tooth pitch must match for gears to mesh. Scaling a gear after it's rendered breaks this. Can also be done via Live Path Effect.
  • Laser Tools > Tabbed Box Maker for generating boxes with interlocking tabs